Live disk won't connect to the Internet

Post your questions about Refracta here.

Live disk won't connect to the Internet

Postby Mister Monday » October 23rd, 2018, 9:35 pm

In VMware I created two virtual machines.

1. Mint 19 fully installed to a virtual hard disk
2. Mint 19 live disk created by running refractasnapshot on #1

The live disk seems to be working okay, except it will NOT connect to the Internet. In VMware I have tried both NAT and bridged modes with no luck. There is "No connection".

Any idea what might be going wrong? Thanks.

I was able to successfully ping myself from within the live disk.

Both VMs have VMware Tools installed.
Last edited by Mister Monday on October 23rd, 2018, 9:49 pm, edited 1 time in total.
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Re: Live disk won't connect to the Internet

Postby nodir » October 23rd, 2018, 9:38 pm

i got two ideas:
a) make sure there is no missmatch in using eth0 and the new naming enp*s0 (say if you are using /etc/network/interfaces
b) you could try to rm the file /etc/udev/rules.d/**net*** (don't know the exact path or filename, sorry).

Just ideas what i would look for.
nodir
 
Posts: 307
Joined: June 16th, 2015, 10:10 pm

Re: Live disk won't connect to the Internet

Postby Mister Monday » October 23rd, 2018, 9:50 pm

Contents of /etc/network/interfaces

Code: Select all
auto lo
iface lo inet loopback


I don't understand the rest of your instructions.
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Re: Live disk won't connect to the Internet

Postby Head_on_a_Stick » October 24th, 2018, 5:48 am

Mister Monday wrote:There is "No connection".

I don't use Mint, is it connecting with NetworkManager?

Can we please see the output of this command from the non-working live environment:
Code: Select all
ip a

Thanks!

Mister Monday wrote:I was able to successfully ping myself from within the live disk.

How exactly did you do this?
Show Off
User avatar
Head_on_a_Stick
 
Posts: 163
Joined: June 16th, 2015, 8:35 pm
Location: London baby!

Re: Live disk won't connect to the Internet

Postby Mister Monday » October 24th, 2018, 11:15 pm

Head_on_a_Stick wrote:
Mister Monday wrote:There is "No connection".

I don't use Mint, is it connecting with NetworkManager?

Yes.

Head_on_a_Stick wrote:Can we please see the output of this command from the non-working live environment:
Code: Select all
ip a

Thanks!

Here:

Code: Select all
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0c:29:b6:28:29 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ca90:e9a6:385:36f3/64 scope link noprefixroute
       valid_lft forever preferred_lft forever



Head_on_a_Stick wrote:
Mister Monday wrote:I was able to successfully ping myself from within the live disk.

How exactly did you do this?

I did this:

Code: Select all
ping 127.0.0.1



Thanks.
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Re: Live disk won't connect to the Internet

Postby Head_on_a_Stick » October 25th, 2018, 5:58 am

Mister Monday wrote:
Head_on_a_Stick wrote:I don't use Mint, is it connecting with NetworkManager?

Yes.

Can we please see the output of
Code: Select all
systemctl status NetworkManager

Mister Monday wrote:
Code: Select all
2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0c:29:b6:28:29 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ca90:e9a6:385:36f3/64 scope link noprefixroute
       valid_lft forever preferred_lft forever

The ethernet interface is up but does not have an address assigned, this should assign one without the help of NetworkManager:
Code: Select all
# dhclient ens33

^ If that doesn't work then please post any error messages here in full, thanks!
Show Off
User avatar
Head_on_a_Stick
 
Posts: 163
Joined: June 16th, 2015, 8:35 pm
Location: London baby!

Re: Live disk won't connect to the Internet

Postby Mister Monday » October 25th, 2018, 8:25 pm

Head_on_a_Stick wrote:Can we please see the output of
Code: Select all
systemctl status NetworkManager



Code: Select all
titlebar@titlebar-virtual-machine:~$ systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p
   Active: active (running) since Thu 2018-10-25 12:18:30 EDT; 4h 2min ago
     Docs: man:NetworkManager(8)
 Main PID: 702 (NetworkManager)
    Tasks: 4 (limit: 4630)
   CGroup: /system.slice/NetworkManager.service
           ├─ 702 /usr/sbin/NetworkManager --no-daemon
           └─2044 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helpe
 ESCOC
























er
etworkManager.service; enabled; vendor preset: enabled)
18-10-25 12:18:30 EDT; 4h 2min ago



service
er --no-daemon
sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /run/dhclient-ens33.pid -lf /var/l
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

























reset: enabled)






r -pf /run/dhclient-ens33.pid -lf /var/lib/NetworkManager/dhclient-c9cdb6c6-dac7
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC
































ib/NetworkManager/dhclient-c9cdb6c6-dac7-3cc8-bdf3-6df8c238e2b2-ens33.lease -cf
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC
































-3cc8-bdf3-6df8c238e2b2-ens33.lease -cf /var/lib/NetworkManager/dhclient-ens33.c
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC
































/var/lib/NetworkManager/dhclient-ens33.conf ens33
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC
































onf ens33
~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOD

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOD

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOD

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOD

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOD

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
 ESCOC

































~
~
~
~
~
~
~
~
~
~
~
~
~
~
lines 1-9/9 (END)





Head_on_a_Stick wrote:The ethernet interface is up but does not have an address assigned, this should assign one without the help of NetworkManager:
Code: Select all
# dhclient ens33

^ If that doesn't work then please post any error messages here in full, thanks!


That did indeed work. No errors. Will I need to execute that command every time I boot the machine?
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Re: Live disk won't connect to the Internet

Postby Head_on_a_Stick » October 25th, 2018, 8:43 pm

Mister Monday wrote:
Code: Select all
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p
   Active: active (running) since Thu 2018-10-25 12:18:30 EDT; 4h 2min ago
     Docs: man:NetworkManager(8)
 Main PID: 702 (NetworkManager)
    Tasks: 4 (limit: 4630)
   CGroup: /system.slice/NetworkManager.service
           ├─ 702 /usr/sbin/NetworkManager --no-daemon
           └─2044 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helpe

^ NetworkManager is up & running, have you checked the settings?

Mister Monday wrote:That did indeed work. No errors. Will I need to execute that command every time I boot the machine?

Well you could but /etc/network/interfaces & ifupdown are very convenient and should work in Mint just as they do in Debian so try that instead:

https://wiki.debian.org/NetworkConfigur ... _interface

^ I seem the remember the allow-hotplug line causing delays in another thread but I may be imagining that.

Your interface is called ens33 rather than eth0 so substitute that in.

Anyway, NetworkManager is not needed at all for your VM so you should probably disable that to prevent possible conflicts.

Can you uninstall the network-manager package or is it tied in to the Cinnamon desktop?

If you can't remove it then find the .services with
Code: Select all
systemctl list-unit-files --state=enabled

Then disable the unwanted ones with (for example):
Code: Select all
# systemctl disable --now NetworkManager.service

^ Note the silly CamelCase unit name, the capitalisation is important.
Show Off
User avatar
Head_on_a_Stick
 
Posts: 163
Joined: June 16th, 2015, 8:35 pm
Location: London baby!

Re: Live disk won't connect to the Internet

Postby Mister Monday » October 26th, 2018, 2:55 am

Head_on_a_Stick wrote:
Mister Monday wrote:
Code: Select all
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p
   Active: active (running) since Thu 2018-10-25 12:18:30 EDT; 4h 2min ago
     Docs: man:NetworkManager(8)
 Main PID: 702 (NetworkManager)
    Tasks: 4 (limit: 4630)
   CGroup: /system.slice/NetworkManager.service
           ├─ 702 /usr/sbin/NetworkManager --no-daemon
           └─2044 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helpe

^ NetworkManager is up & running, have you checked the settings?

/etc/NetworkManager/NetworkManager.conf:
Code: Select all
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no


/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf:
Code: Select all
[connection]
wifi.powersave = 3


Hope that helps.
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Re: Live disk won't connect to the Internet

Postby Mister Monday » October 26th, 2018, 3:05 am

Head_on_a_Stick wrote:Anyway, NetworkManager is not needed at all for your VM so you should probably disable that to prevent possible conflicts.

Can you uninstall the network-manager package or is it tied in to the Cinnamon desktop?



I uninstalled NetworkManager using

Code: Select all
sudo apt-get purge network-manager


But a circular animated icon in the taskbar is still present.

Head_on_a_Stick wrote:If you can't remove it then find the .services with
Code: Select all
systemctl list-unit-files --state=enabled

Then disable the unwanted ones with (for example):
Code: Select all
# systemctl disable --now NetworkManager.service

^ Note the silly CamelCase unit name, the capitalisation is important.


I did this and got an error:

"Failed to disable unit: Unit file NetworkManager.service does not exist."

Here is a list of running services:

Code: Select all
titlebar@titlebar-virtual-machine:~$ systemctl list-unit-files --state=enabled
UNIT FILE                                  STATE 
acpid.path                                 enabled
cups.path                                  enabled
accounts-daemon.service                    enabled
anacron.service                            enabled
apparmor.service                           enabled
autovt@.service                            enabled
avahi-daemon.service                       enabled
blk-availability.service                   enabled
bluetooth.service                          enabled
casper.service                             enabled
console-setup.service                      enabled
cron.service                               enabled
cups-browsed.service                       enabled
cups.service                               enabled
dbus-fi.w1.wpa_supplicant1.service         enabled
dbus-org.bluez.service                     enabled
dbus-org.freedesktop.Avahi.service         enabled
dbus-org.freedesktop.ModemManager1.service enabled
dbus-org.freedesktop.resolve1.service      enabled
dbus-org.freedesktop.thermald.service      enabled
dns-clean.service                          enabled
friendly-recovery.service                  enabled
getty@.service                             enabled
gpu-manager.service                        enabled
hddtemp.service                            enabled
irqbalance.service                         enabled
kerneloops.service                         enabled
keyboard-setup.service                     enabled
live-config.service                        enabled
lm-sensors.service                         enabled
lvm2-monitor.service                       enabled
mintsystem.service                         enabled
ModemManager.service                       enabled
networkd-dispatcher.service                enabled
networking.service                         enabled
ondemand.service                           enabled
openvpn.service                            enabled
pppd-dns.service                           enabled
rsync.service                              enabled
rsyslog.service                            enabled
setvtrgb.service                           enabled
syslog.service                             enabled
systemd-resolved.service                   enabled
syslog.service                             enabled
systemd-resolved.service                   enabled
dbus-org.freedesktop.ModemManager1.service enabled
dbus-org.freedesktop.resolve1.service      enabled
dbus-org.freedesktop.thermald.service      enabled
dns-clean.service                          enabled
friendly-recovery.service                  enabled
getty@.service                             enabled
gpu-manager.service                        enabled
hddtemp.service                            enabled
irqbalance.service                         enabled
kerneloops.service                         enabled
keyboard-setup.service                     enabled
live-config.service                        enabled
lm-sensors.service                         enabled
lvm2-monitor.service                       enabled
mintsystem.service                         enabled
ModemManager.service                       enabled
networkd-dispatcher.service                enabled
networking.service                         enabled
ondemand.service                           enabled
openvpn.service                            enabled
pppd-dns.service                           enabled
rsync.service                              enabled
rsyslog.service                            enabled
lines 19-41/67 62%
titlebar@titlebar-virtual-machine:~$
Mister Monday
 
Posts: 18
Joined: October 21st, 2018, 11:43 pm

Next

Return to Refracta

Who is online

Users browsing this forum: No registered users and 0 guests

cron

x