HOWTO: My IceWM Configuration (verbose)

Share your wisdom. Not for support questions!

Moderator: How-to Curator

HOWTO: My IceWM Configuration (verbose)

Postby Lou » July 20th, 2014, 9:11 pm

HOWTO: My IceWM Configuration (verbose) UPDATE

IceWM was the first window manager i ever used; it was the default wm in the now defunct
distro: Libranet, my alma mater. It's very stable it will never let you down.
It uses around 3 MB of RAM.

IceWM is fast, easy to use (point and click, keybinds) very configurable, perfect
for a Linux neophyte like me. My little box couldn't handle Windows' monstrosity,
so i broke my teeth with IceWM.

I went to http://www.icewm.org and read everything, it was too deep for me :(
So i began to google and ask questions. The end result is my own configuration.

If you go to the icewm site -> IceWM Manual you get all the keybinds and mouse commands.

It comes by default with alt-tab to switch windows, alt-F10 to maximize,
alt-F9 to minimize, winkey + space bar will give a 'run box' at the taskbar
etc It's a very worthwile read, it will teach you how to lock your screen (xtrlock),
move a window to another workspace and so forth.

INSTALLATION

Code: Select all
# apt-get install icewm menu
If you're in Sid add the package 'icewm-themes'


To enable a theme: press the Windows key -> Settings -> Themes and click on the one
you want, it'll activate immediately. Pressing the Windows key (winkey) will give
you the main menu.

By doing the same but choosing Focus you choose the type of focusing you like,
I use 'Sloppy'. Now you are ready to use IceWM.

Congratulations!


OTOH, If you feel "the need for speed", like to live on the wild side, get in trouble,
a geek wannabe, or simply you are bored to tears with the "Windowseske" way of life, want
to save time instead of screwing with the mouse, then KEYBINDINGS are for you.

CREATING A DIRECTORY AND SOME DOT FILES

Code: Select all
$ mkdir -p .icewm
$ touch .icewm/preferences
$ touch .icewm/keys
$ touch .icewm/winoptions
$ touch .icewm/prefoverride
Press Enter after each one.


Now i go to the global preferences (which cannot be edited) and copy the ones I
like and that fit my way of working and copy them to my preferences dot file
in my /home. Clear a mud? There should be an easier way :D
Code: Select all
# updatedb
$ locate icewm
$ nano /usr/share/icewm/preferences


The file you want is /usr/share/icewm/preferences it's a huge file, choose the ones
you like and paste them to your newly made dot file in your /home ( /.icewm/preferences),
just copy the second line and put '1' OR '0'


1 to enable
0 to disable

you can always toggle back and forth. It's a good thing to read the entire list
of Global Preferences, moving the Preferences you like to your /home takes time the first
time, which is why i keep mine in a 'icewm configuration' folder in my web mail, after that,
I copy/paste, it takes me 5 minutes to config icewm.
Lucky for me i got the ones i like in my webmail, i cp them and paste them and voilá!

For example, if i find something new i like, i copy it from the global preferences
file and add it to my .icewm/preferences like thus:

Code: Select all
#  Use double-height task bar
# TaskBarDoubleHeight=0 # 0/1


and paste it, edit it, leave it looking like this if i want it to be enabled:
Code: Select all
TaskBarDoubleHeight=1


save/exit your editor and Restart icewm (winkey + r)if you installed in English
or (winkey+i) if you installed in Spanish. Or just plain click on 'Restart IceWM'
Friggin riot, ain't it? Is it worthed it?
Yup.

So, let's not digress and do it:

$ nano .icewm/preferences

copy/paste this:

Code: Select all
OpaqueMove=0
OpaqueResize=0
SmartPlacement=1
MenuMouseTracking=1
ModSuperIsCtrlAlt=1
UseMouseWheel=1
QuickSwitch=1
AutoReloadMenus=1
ShowProgramsMenu=1
ShowThemesMenu=1
ShowHelp=1
TerminalCommand="xterm"
ShutdownCommand="sudo halt -p"
RebootCommand="sudo reboot"
WorkspaceNames=" 1 ", " 2 "

TaskBarAutoHide=0
TaskBarShowClock=1
TaskBarShowAPMStatus=0
TaskBarAtTop=1
TaskBarShowAPMStatus=0
TaskBarShowAPMTime=0
TaskBarShowMailboxStatus=1
TaskBarShowWindows=1
TaskBarShowShowDesktopButton=0
TaskBarShowTray=1
TaskBarShowWindowIcons=0
TaskBarShowCPUStatus=0
TaskBarShowNetStatus=0
TaskBarShowCollapseButton=0
TaskBarWorkspacesLeft=1
TimeFormat="%R"
TaskBarShowShowDesktopButton=1
TaskBarShowWindowListMenu=0
TaskBarShowMailboxStatus=0
TaskBarMailboxStatusBeepOnNewMail=0
NormalTaskBarFontName="-*-sans-medium-r-*-*-*-100-*-*-*-*-*- *"
NormalTaskBarFontNameXft="sans-serif:size=10"
ActiveTaskBarFontName="-*-sans-r-*-*-*-100-*-*-*-*-*-*"
ActiveTaskBarFontNameXft="sans-serif:size=10"

save/exit

You'll notice i got this preference on my list:

Code: Select all
TaskBarAtTop=1


Now i got the taskbar and the titlebar at the top which defeats the purpose of
saving space; so in order to elimate the Title bar, edit the theme file i'm using at the time, and edit it.

Code: Select all
$ locate icewm

$ sudo nano /usr/share/icewm/themes/Infadel2/default.theme


and edit this line leaving it like this:

Code: Select all
TitleBarHeight=0


save/exit/restart

$ nano .icewm/keys

paste this or similar according to the apps you use:

Code: Select all
key "F1" xterm
key "F2" xfe
key "F3" medit
key "Super+m" sylpheed
key "Super+f" iceweasel
key "Super+u" xchat
key "F5" sudo poweroff -p
key "F6" sudo reboot
key "Print" xterm -e scrot -cd 10

#Sound volume
key "Super+Down" amixer -q set PCM 5- unmute # lower volume
key "Super+Up" amixer -q  set PCM 5+ unmute #increase volume


Super = Windows key

IF YOU GOT NO SOUND
Code: Select all
$ alsamixer (Enter)

increase the sound with Up arrow, press Escape


Code: Select all
# alsactl init
$ alsactl store
$ sudo reboot


If you have use for your Fn keys, use Super + foo
You can use Control (Ctrl) or Alt (alt)

Super is good 'cause you can use either hand.

To use sudo, install sudo, and as root, put this in your /etc/sudoers:

Code: Select all
your_username ALL = NOPASSWD : ALL


$ nano .icewm/winoptions
Code: Select all
xterm.startMaximized: 1
sylpheed.startMaximized: 1
xchat.startMaximized: 1
feh.startMaximized: 1
iceweasel.startMaximized: 1
xfe.startMaximized: 1
medit.startMaximized: 1


I like my apps maximized (hehe)

$ nano .icewm/prefoverride

Code: Select all
KeyWinClose="F4"
KeyWinMaximize="F12"
KeySysTileHorizontal="Super+F2"
KeySysTileVertical="Super+F3"


I close my apps with F4, boom! gone!
Maximize anything with one key F12 instead of the default Alt-F10
Split the screen horizontally for my translating = Super+F2
Vertically = Super+ F3

Hope you haven't fallen asleep.

UPDATE:
Locking icewm screen with xtrlock
viewtopic.php?f=11&t=2926&p=27312#p27

Screenie
https://dyp.im/kraRr89pkX

No title bar:
https://dyp.im/qXeKk2UqCo

UPDATE:
If you go up to Sid, which comes with pulseaudio, the sound keybinds are:

Code: Select all
#SOUND
key "Ctrl+Down" amixer -D pulse set Master 6%- unmute # lower volume
key "Ctrl+Up" amixer -D pulse set Master 6%+ unmute e #increase volume
key "Ctrl+0" amixer -D pulse set Master toggle #mute
Debian Jessie w/o systemd - icewm
User avatar
Lou
 
Posts: 235
Joined: April 5th, 2011, 3:58 pm

Return to HowTo

Who is online

Users browsing this forum: No registered users and 2 guests

cron

x