[Solved] Cannot decipher command output

Post your Debian questions here.

[Solved] Cannot decipher command output

Postby mharrison » March 11th, 2011, 2:56 pm

Ok, I am trying to figure out which graphics driver my Nvidia card is using after a fresh install.
I followed the instructions from the wiki http://wiki.debian.org/NvidiaGraphicsDrivers
Code: Select all
http://wiki.debian.org/NvidiaGraphicsDrivers


When I run that, this is what I end up getting displayed in the terminal window

More: show
Code: Select all
$ grep -B2 'Module class: X.Org Video Driver' /var/log/Xorg.0.log
(II) Module nouveau: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 0.0.15
   Module class: X.Org Video Driver
--
(II) Module nv: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.1.17
   Module class: X.Org Video Driver
--
(II) Module vesa: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.3.0
   Module class: X.Org Video Driver



The command is supposed to tell me which driver module I am using, but it displays all 3 that are available. I will admit that when it comes to reading some of the outputs I am very new at it, so maybe I am totally missing something obvious here.
Last edited by mharrison on March 14th, 2011, 1:28 pm, edited 1 time in total.
mharrison
 
Posts: 1081
Joined: February 13th, 2011, 5:39 pm

Re: Cannot decipher command output

Postby fsmithred » March 11th, 2011, 3:10 pm

It displays three that aren't the nvidia driver. Try 'lspci -k', and it should tell you which one you're actually using. Did you forget to add a driver line to the device section of xorg.conf, telling it to use the nvidia driver?
fsmithred
 
Posts: 297
Joined: February 11th, 2011, 4:14 am

Re: Cannot decipher command output

Postby mharrison » March 11th, 2011, 6:01 pm

fsmithred wrote:It displays three that aren't the nvidia driver. Try 'lspci -k', and it should tell you which one you're actually using. Did you forget to add a driver line to the device section of xorg.conf, telling it to use the nvidia driver?


According to lspci -k I am using the nouveau driver. I didn't forget anything really....this was a fresh install and I wanted to see what the installer chose to do. The only thing I have done on this box is remove some packages for some of the gnome crap I don't use.
mharrison
 
Posts: 1081
Joined: February 13th, 2011, 5:39 pm

Re: [Solved] Cannot decipher command output

Postby mharrison » March 14th, 2011, 1:29 pm

Marking as solved only because I did find out what driver was installed at installation. Still have no idea why the wiki suggests a command that lists every available option.
mharrison
 
Posts: 1081
Joined: February 13th, 2011, 5:39 pm


Return to General Questions

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest

cron

x