Page 1 of 1

Samba on Debian (openmediavault distro) not working?

PostPosted: October 1st, 2019, 11:36 am
by Steven1965
Hey, I am new to Debian/Openmediavault, and I am not sure if this is a correct place to ask but I will try.
I just set up a openmediavault distro.
It's a distro with FTP server, web server, SAMBA server....
It's in my old PC, I can ping it from windows PC, I can ping windows PC from that.
I can access it trough HTTP (port 80), the web panel.
I can also connect to it by SFTP, upload and download files.
I have created a Share folder, enabled SMB.
But.... I can't connect to network drive from Windows (Windows 10) directly, I can't map it, it is not visible in Network at all...
Workgroup is the same in settings.
I can't even access it by typing IP/share name directly in Windows explorer.
I started suspecting that it might be a Samba issue, because Windows 10 firewall is off.
I typed systemctl status smbd to check the samba status and got that:

Code: Select all
smbd.service - LSB: start SMB/CIFS deamon (smbd)
Loaded: loaded (/etc/init.d/smbd)
Active: active (exited) since Sun 2019-09-29 11:43:21 EDT: 2min 48s ag
o Process: 80B ExecStart=/etc/init.d/smbd start (code=exited,status=0/SUCCESS)

So, is this a correct status for Samba?
Is something wrong with my Samba? Or why can't I connect to it?
What does "active (exited)" mean?

Re: Samba on Debian (openmediavault distro) not working?

PostPosted: October 4th, 2019, 5:01 pm
by arochester
Have you also asked the openmediavault forum? https://forum.openmediavault.org/

Re: Samba on Debian (openmediavault distro) not working?

PostPosted: October 5th, 2019, 12:40 pm
by Steven1965
Yes, no replies there.

I have also tried removing and adding again samba by apt-get, and I also tried enabling Samba loging, but there are no logs.

I also compared by samba status "active exited" with some guy from other forum, and he has "active (running)", so something is defineltey wrong. For some reasons the samba process must be quitting/exiting just after it's started.