libgstreamer-0.10.so.0 Error

Post your Debian questions here.

libgstreamer-0.10.so.0 Error

Postby cozi » August 7th, 2018, 8:41 am

Hello. I have a problem runing a soft.
I'm getting
error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory


I' using Debian 9 Cannot install libgstreamer-0.10.so I tried
Code: Select all
sudo apt-get install libgstreamer0.10-0

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgstreamer0.10-0
E: Couldn't find any package by glob 'libgstreamer0.10-0'
E: Couldn't find any package by regex 'libgstreamer0.10-0'

When I search
Code: Select all
sudo apt-cache search libgstreamer
libgstreamer-plugins-bad1.0-0 - GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-bad1.0-dev - GStreamer development files for libraries from the "bad" set
libgstreamer-plugins-base1.0-0 - GStreamer libraries from the "base" set
libgstreamer-plugins-base1.0-dev - GStreamer development files for libraries from the "base" set
libgstreamer1.0-0 - Core GStreamer libraries and elements
libgstreamer1.0-0-dbg - Core GStreamer libraries and elements
libgstreamer1.0-dev - GStreamer core development files
libgstreamermm-1.0-1 - C++ wrapper library for GStreamer (shared libraries)
libgstreamermm-1.0-dev - C++ wrapper library for GStreamer (development files)
libgstreamermm-1.0-doc - C++ wrapper library for GStreamer (documentation)
libgstreamer-ocaml - OCaml interface to the gstreamer library -- runtime files
libgstreamer-ocaml-dev - OCaml interface to the gstreamer library -- development files
libgstreamerd-3-0 - GStreamer media framework - D bindings
libgstreamerd-3-0-dbgsym - Debug symbols for libgstreamerd-3-0
libgstreamerd-3-dev - GStreamer media framework - development files for D



I created the file /etc/apt/sources.list.d/unstable.list with contents:

Code: Select all
deb http://ftp.nl.debian.org/debian/ unstable main
deb-src http://ftp.nl.debian.org/debian/ unstable main

Then, create /etc/apt/preferences.d/unstable with contents:

Code: Select all
Package: *
Pin: release a=unstable
Pin-Priority: 200


Then I typed apt-get update
And tried this

Code: Select all
sudo apt-cache policy libgstreamer0.10-0
N: Unable to locate package libgstreamer0.10-0
N: Couldn't find any package by glob 'libgstreamer0.10-0'
N: Couldn't find any package by regex 'libgstreamer0.10-0'


Or can you explain how I can install it from here https://packages.debian.org/jessie/libgstreamer0.10-0
I downloaded and unpack it, but I don't know what to do next.

I'm sorry I'm a noob in Linux
cozi
 
Posts: 1
Joined: August 7th, 2018, 8:40 am

Re: libgstreamer-0.10.so.0 Error

Postby fsmithred » August 10th, 2018, 12:34 am

libgstreamer0.10-0 is only in jessie (oldstable).
For stable, testing or unstable, use libgstreamer1.0-0.
Any time a .so file is missing, you need to install the corresponding -dev package.
Code: Select all
apt-get install libgstreamer1.0-0 libgstreamer1.0-dev


To install from a .deb package, use 'dpkg -i <package>' but you don't need to do that in this case.

Edit: if you're a linux noob, you should probably stick to the stable release until you know your way around better.
fsmithred
 
Posts: 293
Joined: February 11th, 2011, 4:14 am


Return to General Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x