Dependency problems - repo problems?

Post your Debian questions here.

Dependency problems - repo problems?

Postby ardyn » January 29th, 2018, 9:40 am

Hi there,

I'm using Debian Buster (upgraded from Stretch), and I'm having a lot of dependency problems.

I'm trying to install Xournal from Github. It's telling me I need to install libglade-2.0.

root@undusmundus:/home/brown/xournalpp/build# apt-get install libglade-2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libglade-2.0
E: Couldn't find any package by glob 'libglade-2.0'
E: Couldn't find any package by regex 'libglade-2.0'


I've tried to install it using apt-get install libglade-2.0.

root@undusmundus:/home/brown/xournalpp/build# apt-get install libglade-2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libglade-2.0
E: Couldn't find any package by glob 'libglade-2.0'
E: Couldn't find any package by regex 'libglade-2.0'


I can see the package on search.debian.org, and I think my sources.list is okay, but I'm obviously still fumbling around in the dark a bit.

Almost every package does this, do I don't think it's just one package.

If anyone could tell me where I'm going wrong, I'd really appreciate it.

Thanks very much.

#

deb http://ftp.jp.debian.org/debian buster main non-free contrib
deb-src http://ftp.jp.debian.org/debian buster main non-free contrib

# deb http://security.debian.org/debian-security stretch/updates main non-free contrib
# deb-src http://security.debian.org/debian-security stretch/updates main non-free contrib

# stretch updates, previously known as 'volatile'
deb http://ftp.jp.debian.org/debian/ buster-updates main non-freee contrib
deb-src http://ftp.jp.debian.org/debian/ buster-updates main non-freee contrib
deb http://deb.opera.com/opera-stable/ stable non-free
deb http://deb.debian.org/ buster non-free main contrib
ardyn
 
Posts: 1
Joined: January 29th, 2018, 9:30 am

Re: Dependency problems - repo problems?

Postby cynwulf » January 29th, 2018, 2:11 pm

ardyn wrote:
Code: Select all
root@undusmundus:/home/brown/xournalpp/build# apt-get install libglade-2.0

A typo. The package is called "libglade2-0".
User avatar
cynwulf
 
Posts: 2394
Joined: April 26th, 2011, 2:46 pm


Return to General Questions

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x