Page 1 of 1

How to install refracta tools?

PostPosted: October 21st, 2018, 11:45 pm
by Mister Monday
I am very much a Linux noob. Could someone tell me how to install refracta tools on Mint? When I try to use apt I get a "Unable to locate package" error. I don't see instructions on the refracta website either. Thanks.

Re: How to install refracta tools?

PostPosted: October 22nd, 2018, 10:45 am
by fsmithred
Download the latest versions of the tools here - https://sourceforge.net/projects/refracta/files/tools/
For refractasnapshot and refractainstaller, you need at least the -base packages. For refracta2usb, there's just the one (gui only).

The normal way is to install the packages either with gdebi or
Code: Select all
dpkg -i refracta*.deb
apt-get -f install
But that doesn't work in because some of the live-* packages are not in the repository.

You can get the missing packages here. The ones for mint18 are from debian wheezy. The one for mint17 was modified to fix broken deps due to a change in a package name.
Install them with 'dpkg -i <package>' or with gdebi.
http://distro.ibiblio.org/refracta/files/other/

Re: How to install refracta tools?

PostPosted: October 23rd, 2018, 1:43 am
by Mister Monday
What directories do I put these files in? Thanks.

[edit]

I was able to install the "live" packages. But I am getting errors when installing the tools:

Code: Select all
sudo dpkg -i refractasnapshot-base_10.1.1_all.deb
Selecting previously unselected package refractasnapshot-base.
(Reading database ... 238874 files and directories currently installed.)
Preparing to unpack refractasnapshot-base_10.1.1_all.deb ...
Unpacking refractasnapshot-base (10.1.1) ...
dpkg: dependency problems prevent configuration of refractasnapshot-base:
 refractasnapshot-base depends on syslinux (<< 3:6.03) | isolinux (>= 3:6.03); however:
  Version of syslinux on system is 3:6.03+dfsg1-2.
  Package isolinux is not installed.

dpkg: error processing package refractasnapshot-base (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 refractasnapshot-base


I am running Mint 19, which may be the problem.

Re: How to install refracta tools?  Topic is solved

PostPosted: October 23rd, 2018, 11:47 am
by fsmithred
That's what the second command is for. 'apt-get -f install' or 'apt --fix-broken install' should pull in the needed packages (syslinux, syslinux-common and isolinux) or you could install them through synaptic.

Re: How to install refracta tools?

PostPosted: October 23rd, 2018, 1:56 pm
by Mister Monday
You are indeed correct!!

I think I have the tools are installed in Mint, now. But running refractasnapshot I get a new error.

Image

I think I chose MBR instead of GPT when installing Mint. How do I check to be sure? Which line should I edit in the config file?

[edit]

I set make_efi to "no" and all proceeded according to plan! Yay!