problem upgrading Firefox-esr  Topic is solved

Post questions regarding lower-level issues will here.

problem upgrading Firefox-esr

Postby labbe5 » May 17th, 2019, 10:08 pm

As a new user and forum member, i must say i like Refracta. Firejail installed by default with a series of contained applications is very much appreciated.

I used Refracta since latest snapshot on April 13th, and for a while i updated and upgraded my live system without any problem, up to now. Firefox-esr is not upgradable anymore.

Here is what i get :
Failed to fetch ... _amd64.deb 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Do you intend to fix this issue with another snapshot to download and install or to show us how to fix this issue? I looked at etc/apt for source.list but i do not find any repository related to the Firefox issue.

Since i use Refracta for banking, having an upgraded system is very important, and for doing anything on the Web, as well.

Please respond.
Posts: 3
Joined: May 17th, 2019, 9:39 pm

Re: problem upgrading Firefox-esr

Postby labbe5 » May 17th, 2019, 10:44 pm

I did a search for a solution by going to Firefox download page, downloaded latest version 60.6.3esr, extracted it and started it by doing ./firefox in terminal. It works.

But that does not resolve the issue regarding upgrading my system by doing $sudo apt update && sudo apt -y upgrade. The upgrade stalls because of firefox-esr is not upgradable.

Synaptic package manager helps upgrade the system by discarding firefox-esr, and upgrading everything else.

I suspect the problem about upgrading Firefox-esr in Refracta is related to the disabling of addons a week ago.
Posts: 3
Joined: May 17th, 2019, 9:39 pm

Re: problem upgrading Firefox-esr  Topic is solved

Postby labbe5 » May 20th, 2019, 2:47 pm

As of today, upgrading my system performed well with $sudo apt update && sudo apt -y upgrade. I presume developers of Refracta have done something.

About Firejail and banking (discussed briefly above).

When doing banking, start firejail in terminal with --private option. Instead of using FireMenu which does not come with Firefox-esr as --private.
To be user-friendly.

Here is the command line that can be used for banking : firejail --private --caps.drop=all firefox -no-remote

With --private, you create a filesystem that is destroyed at the end of your session, this is why everything you download is not going into your Download folder.

--caps.drop=all makes all capabilities to drop, except the most essential ones.

-no-remote exludes addons from your Firefox session. Addons can be compromised, so it is better not have them while banking.
Posts: 3
Joined: May 17th, 2019, 9:39 pm

Re: problem upgrading Firefox-esr

Postby fsmithred » May 20th, 2019, 9:07 pm

It seems that some packages are not updating as soon as they could. I don't think anyone has figured out what's causing it. You could change your sources to use instead of (or in addition to) and might see some newer versions of some packages sooner.

Thanks for the firejail info. I'll play with it and maybe add it to firemenu.

Edit: I didn't notice this thread until today. Sometimes (usually) I just check the Refracta forum.
Posts: 361
Joined: February 11th, 2011, 4:14 am

Return to System Issues

Who is online

Users browsing this forum: No registered users and 1 guest