xrdp and clam install  Topic is solved

Post questions regarding lower-level issues will here.

xrdp and clam install

Postby thobsbawn » June 15th, 2015, 2:41 pm

Before the upgrade of the Forum site,I had a post already addressing issues with the apt-get install commands "apt-get install: Package Not Found Error", which was causing issues with all applications that were attempted to be installed on Debian 8 Jessie, we got this issue resolved by Editing the sources.list file, this solved the problem I was having; all but a few like xrdp, and clamav, what I did now to attempt to resolve the issues with clamav and xrdp was uninstall ( Synaphic Package Manager was used, Selected Completely Remove), everything removed fine, then did the following:

Code: Select all
sudo apt-get-update

Code: Select all
sudo apt-get upgrade


After this, to install clamav:

Code: Select all
sudo apt-get install clamav


This is my output from that install:
Preparing to unpack .../clamav-base_0.98.7+dfsg-0+deb8u1_all.deb ...
Unpacking clamav-base (0.98.7+dfsg-0+deb8u1) ...
Selecting previously unselected package clamav-freshclam.
Preparing to unpack .../clamav-freshclam_0.98.7+dfsg-0+deb8u1_amd64.deb ...
Unpacking clamav-freshclam (0.98.7+dfsg-0+deb8u1) ...
Selecting previously unselected package clamav.
Preparing to unpack .../clamav_0.98.7+dfsg-0+deb8u1_amd64.deb ...
Unpacking clamav (0.98.7+dfsg-0+deb8u1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u1) ...
Setting up clamav-base (0.98.7+dfsg-0+deb8u1) ...
adduser: The user `clamav' already exists. Exiting.
dpkg: error processing package clamav-base (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of clamav-freshclam:
clamav-freshclam depends on clamav-base (>= 0.98.7+dfsg-0+deb8u1); however:
Package clamav-base is not configured yet.

dpkg: error processing package clamav-freshclam (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of clamav:
clamav depends on clamav-freshclam (>= 0.98.7+dfsg) | clamav-data; however:
Package clamav-freshclam is not configured yet.
Package clamav-data is not installed.
Package clamav-freshclam which provides clamav-data is not configured yet.

dpkg: error processing package clamav (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
clamav-base
clamav-freshclam
clamav
E: Sub-process /usr/bin/dpkg returned an error code (1)
user@tom-deb:~$ sudo apt-get install clamav -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
clamav is already the newest version.
The following packages were automatically installed and are no longer required:
libcommon-sense-perl libjson-perl libjson-xs-perl libtext-csv-perl
libtext-csv-xs-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up clamav-base (0.98.7+dfsg-0+deb8u1) ...
adduser: The user `clamav' already exists. Exiting.
dpkg: error processing package clamav-base (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of clamav-freshclam:
clamav-freshclam depends on clamav-base (>= 0.98.7+dfsg-0+deb8u1); however:
Package clamav-base is not configured yet.

dpkg: error processing package clamav-freshclam (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of clamav:
clamav depends on clamav-freshclam (>= 0.98.7+dfsg) | clamav-data; however:
Package clamav-freshclam is not configured yet.
Package clamav-data is not installed.
Package clamav-freshclam which provides clamav-data is not configured yet.

dpkg: error processing package clamav (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
clamav-base
clamav-freshclam
clamav
E: Sub-process /usr/bin/dpkg returned an error code (1)
user@tom-deb:~$


I know im connected to the internet, Am I missing anything here?
thobsbawn
 
Posts: 5
Joined: June 15th, 2015, 12:29 pm

Re: xrdp and clam install  Topic is solved

Postby cynwulf » June 15th, 2015, 3:28 pm

There has been no upgrade - this is a different forum to the one you posted on before, which is currently down.

Do the following and post the results:

Code: Select all
# aptitude purge ~ixrdp ~iclamav

Code: Select all
# userdel clamav

Code: Select all
# apt-get clean

Code: Select all
# apt-get update && apt-get -f install

Code: Select all
# apt-get upgrade

Code: Select all
# apt-get install clamav
cynwulf
 
Posts: 2548
Joined: April 26th, 2011, 2:46 pm

Re: xrdp and clam install

Postby thobsbawn » June 15th, 2015, 5:17 pm

Thank you for the clarification on the other debian forum site, I did these commmands as directed:

user@tom-deb:~$ sudo aptitude purge ~ixrdp ~iclamav
[sudo] password for user:

The following packages will be REMOVED:
clamav{p} clamav-base{p} clamav-freshclam{p} libclamav6{p} libcommon-sense-perl{u}
libjson-perl{u} libjson-xs-perl{u} libmspack0{u} libtext-csv-perl{u}
libtext-csv-xs-perl{u}
0 packages upgraded, 0 newly installed, 10 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 5,070 kB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 155860 files and directories currently installed.)
Removing clamav (0.98.7+dfsg-0+deb8u1) ...
Removing clamav-freshclam (0.98.7+dfsg-0+deb8u1) ...
Purging configuration files for clamav-freshclam (0.98.7+dfsg-0+deb8u1) ...
Removing clamav-base (0.98.7+dfsg-0+deb8u1) ...
Purging configuration files for clamav-base (0.98.7+dfsg-0+deb8u1) ...
Removing libclamav6 (0.98.7+dfsg-0+deb8u1) ...
Purging configuration files for libclamav6 (0.98.7+dfsg-0+deb8u1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for libc-bin (2.19-18) ...
(Reading database ... 155779 files and directories currently installed.)
Removing libjson-xs-perl (2.340-1+b2) ...
Removing libcommon-sense-perl (3.73-2+b3) ...
Removing libjson-perl (2.61-1) ...
Removing libmspack0:amd64 (0.5-1) ...
Removing libtext-csv-perl (1.32-1) ...
Removing libtext-csv-xs-perl (1.11-2) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for libc-bin (2.19-18) ...


user@tom-deb:~$ sudo apt-get clean
user@tom-deb:~$ su root
Password:
root@tom-deb:/home/user# apt-get update && apt-get -f install
Ign http://dl.google.com stable InRelease
Hit http://ftp.us.debian.org jessie InRelease
Hit http://security.debian.org jessie/updates InRelease
Hit http://dl.google.com stable Release.gpg
Hit http://dl.google.com stable Release
Hit http://ftp.us.debian.org jessie/main amd64 Packages
Hit http://ftp.us.debian.org jessie/contrib amd64 Packages
Hit http://dl.google.com stable/main amd64 Packages
Hit http://ftp.us.debian.org jessie/non-free amd64 Packages
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://ftp.us.debian.org jessie/contrib Translation-en
Hit http://ftp.us.debian.org jessie/main Translation-en
Hit http://security.debian.org jessie/updates/contrib amd64 Packages
Hit http://ftp.us.debian.org jessie/non-free Translation-en
Hit http://security.debian.org jessie/updates/non-free amd64 Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://security.debian.org jessie/updates/non-free Translation-en
Ign http://dl.google.com stable/main Translation-en_CA
Ign http://dl.google.com stable/main Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@tom-deb:/home/user# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@tom-deb:/home/user# apt-get install clamav
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
clamav-base clamav-freshclam libclamav6 libmspack0
Suggested packages:
clamav-docs apparmor libclamunrar6
The following NEW packages will be installed:
clamav clamav-base clamav-freshclam libclamav6 libmspack0
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,929 kB of archives.
After this operation, 4,214 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.us.debian.org/debian/ jessie/main libmspack0 amd64 0.5-1 [46.5 kB]
Get:2 http://ftp.us.debian.org/debian/ jessie/main clamav-base all 0.98.7+dfsg-0+deb8u1 [283 kB]
Get:3 http://ftp.us.debian.org/debian/ jessie/main libclamav6 amd64 0.98.7+dfsg-0+deb8u1 [926 kB]
Get:4 http://ftp.us.debian.org/debian/ jessie/main clamav-freshclam amd64 0.98.7+dfsg-0+deb8u1 [348 kB]
Get:5 http://ftp.us.debian.org/debian/ jessie/main clamav amd64 0.98.7+dfsg-0+deb8u1 [325 kB]
Fetched 1,929 kB in 1s (1,896 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libmspack0:amd64.
(Reading database ... 155702 files and directories currently installed.)
Preparing to unpack .../libmspack0_0.5-1_amd64.deb ...
Unpacking libmspack0:amd64 (0.5-1) ...
Selecting previously unselected package clamav-base.
Preparing to unpack .../clamav-base_0.98.7+dfsg-0+deb8u1_all.deb ...
Unpacking clamav-base (0.98.7+dfsg-0+deb8u1) ...
Selecting previously unselected package libclamav6.
Preparing to unpack .../libclamav6_0.98.7+dfsg-0+deb8u1_amd64.deb ...
Unpacking libclamav6 (0.98.7+dfsg-0+deb8u1) ...
Selecting previously unselected package clamav-freshclam.
Preparing to unpack .../clamav-freshclam_0.98.7+dfsg-0+deb8u1_amd64.deb ...
Unpacking clamav-freshclam (0.98.7+dfsg-0+deb8u1) ...
Selecting previously unselected package clamav.
Preparing to unpack .../clamav_0.98.7+dfsg-0+deb8u1_amd64.deb ...
Unpacking clamav (0.98.7+dfsg-0+deb8u1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for systemd (215-17+deb8u1) ...
Setting up libmspack0:amd64 (0.5-1) ...
Setting up clamav-base (0.98.7+dfsg-0+deb8u1) ...
Setting up libclamav6 (0.98.7+dfsg-0+deb8u1) ...
Setting up clamav-freshclam (0.98.7+dfsg-0+deb8u1) ...
Setting up clamav (0.98.7+dfsg-0+deb8u1) ...
Processing triggers for libc-bin (2.19-18) ...
Processing triggers for systemd (215-17+deb8u1) ...
root@tom-deb:/home/user#
thobsbawn
 
Posts: 5
Joined: June 15th, 2015, 12:29 pm

Re: xrdp and clam install

Postby thobsbawn » June 15th, 2015, 5:45 pm

The commands worked clamav is up and going, Thanks cynwulf, i dont think I would have got it going even after hours of searching the net then trial and error. One more thing though, is there anything that can be done with xrdp, the issue is when im past the login part for xrdp, it gives me the Oh no could not connect error, or would you rather I start another thread about it?

Thanks Again!
thobsbawn
 
Posts: 5
Joined: June 15th, 2015, 12:29 pm


Return to System Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x