How to REALLY disable the system beep/bell

Post questions regarding lower-level issues will here.

How to REALLY disable the system beep/bell

Postby dbbolton » May 30th, 2015, 8:00 pm

My current laptop has a particularly obnoxious system beep that I want to completely disable.

The first thing I tried was blacklisting pcspkr, but this didn't work. It seems this module wasn't even being loaded. So I tried to figure out what module was responsible, with no luck. The only other such module I have seen mention of is "snd_pcsp", which also isn't loaded so there is no point in blacklisting it. My guess is that in my case it's somehow built in or tied to another module that is required for general audio use:

Code: Select all
snd_hda_codec_hdmi     45118  1
snd_hda_codec_idt      48816  1
snd_hda_codec_generic    63142  1 snd_hda_codec_idt
snd_hda_intel          26327  5
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  5 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                88662  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  18 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore              13026  2 snd,snd_hda_codec


Full lsmod output: https://gist.github.com/dbb/21a06931f42e159505d5

The next thing I tried, per the Arch wiki, was to disable the system bell in /etc/profile and /etc/inputrc. This also didn't work.

The only workaround I have found is to run alsamixer and mute "Beep", but this apparently resets every time I restart my system.

I don't really feel like taking apart my laptop and physically disconnecting the blasted thing, so I'm hoping one of you has a better suggestion.

Edit: here is my card info, if that helps:

Code: Select all
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
        Subsystem: Dell Device [1028:029f]
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at fc700000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: snd_hda_intel
<nadir> i am the king of wobbly windows

RDU since 2007
User avatar
dbbolton
 
Posts: 231
Joined: February 12th, 2011, 9:32 pm

Return to System Issues

Who is online

Users browsing this forum: No registered users and 1 guest

x