AMD 890 chipset or other Phenom motherboards  Topic is solved

Post questions regarding lower-level issues will here.

AMD 890 chipset or other Phenom motherboards

Postby lhuppe » June 27th, 2014, 5:36 pm

Can anyone tell me if a motherboard based upon the AMD 890FX or GX chipset will work with Debian? I am looking at the Asus Crosshair IV Formula and also the Gigabyte GA-890GPA-UD3H. Of course there are others if I can locate them for sale. It is my understanding that 890-based motherboards have legacy BIOS and I consider that to be a plus.

Or perhaps someone knows of a Phenom II motherboard that I could get my hands on. The chips are readily available if I can locate a motherboard ...

I recently tried two different motherboards based upon the AMD 970FX chipset and it was a horror show. Both times around my system kept locking up. Both had to be returned. I suspect that the UEFI was the culprit.

Thank you in advance
lhuppe
 
Posts: 9
Joined: November 17th, 2013, 4:24 am

Re: AMD 890 chipset or other Phenom motherboards

Postby jheaton5 » June 27th, 2014, 7:10 pm

I moved this thread because it belongs in the help section and not the How-to section.
jheaton5
 
Posts: 1776
Joined: February 9th, 2011, 10:25 am
Location: Newnan, GA USA

Re: AMD 890 chipset or other Phenom motherboards

Postby JohnDeere630 » June 28th, 2014, 12:50 am

I run an MSI board with the 890FX chipset and a six-core Phennom cpu, although I don't recall at the moment which one exactly. I have had it for at least a couple of years, and been running Debian Testing exclusively on it with zero problems. I should imagine that Stable should run on it as well at this point.

*edit* I don't remember if my board had UEFI or not, but I have installed Debian on several newer laptops with UEFI with no problems that stick out in my admittedly not-perfect memory. The interwebz is full of information about it, as I recall. YMMV.
$500 bounty paid for each pair of SJW balls...also for hen's teeth, unicorn horns and other imaginary items.
JohnDeere630
 
Posts: 1547
Joined: February 9th, 2011, 6:38 pm

Re: AMD 890 chipset or other Phenom motherboards

Postby Sephiroth » June 28th, 2014, 5:20 pm

I do UEFI with all new systems. This is whether I install Windows 7 Pro or Debian Wheezy on them. Debian and 7 both work fine with UEFI. The only time I had an issue was on one specific SuperMicro board where UEFI would not see the disk presented by the PCI-E x8 card to the system. I had four 1TB drives in RAID10 on a PCI-E card, and UEFI refused to see it, but legacy mode did. The ONE time I had to use the old method.
Owyn: "This next one is a high elf sorceress or something, just get in close and stab her a few times, that'll teach her!"
Owyn: "I heard a rumor that you're an idiot. Is that true?"
Cicero: "Stab you, stab you, stab you!"
Psycho: "You sat in my swing, now I'm going to eat you!"
Psycho: "I think he's gonna' play xylophone with my spinal cord!"
Sephiroth
 
Posts: 387
Joined: February 22nd, 2011, 3:09 pm
Location: North Carolina

Re: AMD 890 chipset or other Phenom motherboards  Topic is solved

Postby lhuppe » July 10th, 2014, 2:37 pm

Thank you all for taking the time to assist,

I am glad to hear that 890fx motherboards can run Debian (I figured as much) as I am now in possession one that I got for a great price. I am also relieved to find that I need not avoid UEFI motherboards for future builds. (I have several builds planned)

The environment where I am located is both hot and humid so I am forced to run everything at stock speeds and use lots of cooling. According to my readings the 890 chipset does not run as hot as either the 970 or 990. I will find out when I run mine up.

As for my system locking up with two separate 970 motherboards, I think that I now know what happened. Shame on me for not foreseeing this one but ... my power supply was too weak and was browning out. I did a major der and I feel rather silly after the fact. Perhaps someone will read this and learn from my mistake.

My thanks to the Debian Community and the Debian User Forums web site - I do appreciate all of you.

May the source be with you always :?)
lhuppe
 
Posts: 9
Joined: November 17th, 2013, 4:24 am


Return to System Issues

Who is online

Users browsing this forum: Google [Bot] and 1 guest

x