Jessie logout to black screen

Post questions regarding lower-level issues will here.

Jessie logout to black screen

Postby twerple » November 6th, 2013, 4:21 am

When I run Jessie (KDE) and try to logout, I get a black screen with not even a mouse cursor. I can only CTRL+ALT+DEL, which does a proper shutdown.

The "TerminateServer=true" trick for kdmrc that works in Wheezy does not work with Jessie.

Any suggestions are welcomed.
twerple
 
Posts: 23
Joined: October 28th, 2011, 2:26 am

Re: Jessie logout to black screen

Postby CiaW » November 7th, 2013, 4:37 am

After the system reboots, do you then get a login screen? I logged out to a blank screen with a blinking cursor in the upper left corner when the fglrx radeon video driver issue was removed.
CiaW
 
Posts: 364
Joined: June 26th, 2011, 4:42 pm

Re: Jessie logout to black screen

Postby twerple » November 8th, 2013, 3:30 am

CiaW wrote:After the system reboots, do you then get a login screen?

I was using auto-login, so I changed it back to default. Yes, i get a login screen at bootup.

I logged out to a blank screen with a blinking cursor in the upper left corner when the fglrx radeon video driver issue was removed.

I'm logging out to a black screen with nothing on it. No mouse cursor, no blinking text cursor.

I'm using a Radeon HD 6570 card with the native ati/radeon driver, and I'm having no other video issues that I'm aware of.

BTW, I have Wheezy and Sid here also, where logout works fine (using the trick mentioned above).
twerple
 
Posts: 23
Joined: October 28th, 2011, 2:26 am

Re: Jessie logout to black screen

Postby cynwulf » November 8th, 2013, 11:18 am

Think about the differences between your Sid and testing installs...?

Is KDM the same version? Are xserver-xorg-core and xserver-xorg-video-radeon at the same version? Are you using the same kernel version?

If not, then you can install packages from Sid in testing and see if the problem is resolved that way...
cynwulf
 
Posts: 2548
Joined: April 26th, 2011, 2:46 pm

Re: Jessie logout to black screen

Postby twerple » November 8th, 2013, 7:00 pm

Thanks for your input. I had not thought about those.

KDM, xserver-xorg-core and xserver-xorg-video-radeon are at the same version.

However, the kernel versions are different at this time:

Linux jessie 3.10-3-amd64 #1 SMP Debian 3.10.11-1 (2013-09-10) x86_64 GNU/Linux
Linux sid 3.11-1-amd64 #1 SMP Debian 3.11.6-2 (2013-11-01) x86_64 GNU/Linux

Maybe I'll just wait for the newer kernel to propagate to Jessie and see if things improve. There's no hurry. Jessie is working well otherwise.
twerple
 
Posts: 23
Joined: October 28th, 2011, 2:26 am

Re: Jessie logout to black screen

Postby mazikwyry » July 15th, 2015, 2:00 pm

Hello guys,

I've just updated to Jessie from Wheezy and have the same problem. I have auto login for my user and after logging out it goes to black screen. After clicking "Screen lock" nothing happens.

Any ideas ?
mazikwyry
 
Posts: 4
Joined: July 15th, 2015, 1:57 pm

Re: Jessie logout to black screen

Postby mazikwyry » July 17th, 2015, 6:31 am

To fix that problem I changes the ATI driver from AMD/ATI Proprietary Driver fglrx which is now incompatible with the GNOME desktop, as it does not support the EGL interface in Debian 8. After update it is recommended to use the free radeon driver instead, so I changed to radeon driver and it fixed my problem.

More info: https://wiki.debian.org/ATIProprietary https://wiki.debian.org/AtiHowTo
mazikwyry
 
Posts: 4
Joined: July 15th, 2015, 1:57 pm


Return to System Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron

x