gnome screen lock not working

Use this forum for questions related to graphics, sound or desktop environments.

gnome screen lock not working

Postby drkarthikv » December 1st, 2016, 7:42 am

hello everyone,
I'am using the latest debian (stable) in dual boot with windows 10.
In debian I'am using 3 desktop environments Gnome, Kde and Cinnamon.
while using gnome I'am unable to lock the screen. Even after resuming from hibernation the screen turns on without asking for password. Screen lock is working fine with the other two DE's.
please help me out,
thanks!
done the whole RPM thing, not a fan!!
drkarthikv
 
Posts: 1
Joined: December 1st, 2016, 7:38 am
Location: HYDERABAD, INDIA

Re: gnome screen lock not working

Postby Monsie » December 2nd, 2016, 1:00 am

Hello drkarthikv,

It is possible that a couple of settings are disabled when they should be enabled by default... so here is something to check:

Hit your alt + f2 keys to bring up a command window, then type:
Code: Select all
dconf-editor
and hit the enter key

This will bring up the the editor for dconf which is a settings database for Gnome 3. On the left side you will see a drop down menu with many branches.
Drill down to: org-->gnome-->desktop-->lockdown. Then look at the settings on the right side and make sure the checkbox for disable-lock-screen is not checked. Next go to: org-->gnome-->desktop-->screensaver and look at the settings on the right side. This time look for a setting called lock-enabled and make sure that the checkbox is checked.

Now, close dconf editor then log out and see if the screen lock is working.

Hope this helps,
Monsie
My username is pronounced: "Munsee" and is based on my nick name in High School.
Monsie
 
Posts: 70
Joined: January 17th, 2016, 11:11 pm


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 1 guest

x