Page 1 of 1

Possible NVidia configuration fix

PostPosted: January 7th, 2014, 11:48 am
by jlambrecht
Take note the below might be for my specific hardware ( an aging Dell M4300 with a Quadro FX 360M ) and operating system ( Debian Wheezy ) Maybe this helps.

The benefits i've noticed is flash playback is stable ( not 100% but stable ) on 64-bit Linux, graphics performance is without hitches and glitches and does not degrade over time. Flash only works stable in Google Chrome or Chromium , Debian's release of Thunderbird triggers a serious performance decrease for yet unkown reasons. This was so before so not much changed. The performance drop completely recovers after about five minutes.

Most noteable change with great effect was the below, the ... to indicate this is an addition to the existing configuration, do not include them.
These options are well documented by NVidia in the Readme.

##### take note a reboot might not load these settings, power off your system to make sure. I'm not so fond because of kexec really.

GRUB_CMDLINE_LINUX_DEFAULT=” … nomodeset noapic enable_mtrr_cleanup mtrr_spare_reg_nr=4”

## first try the above without mtrr_spare_reg_nr=4
## enable_mtrr_cleanup is a documented fix for some graphics cards + notebook or desktop bios


I've also downloaded and installed the NVidia Long Lived Driver for 64-bit with the below options

./NVIDIA-Linux-x86_64-331.20.run -x
cd NVIDIA-Linux-x86_64-331.20
./nvidia-installer –no-unified-memory –no-install-vdpau-wrapper -N -Z

## YOU MUST install with 32-bit compatibility drivers
## in addition installing ia32-libs is a good idea, though unverfied to be required

## Create /etc/adobe/mms.cfg if does not exist, or make a backup if it does.
## Then put the below into this file

#Adobe player settings
AVHardwareDisable = 0
FullScreenDisable = 0
LocalFileReadDisable = 1
FileDownloadDisable = 1
FileUploadDisable = 1
LocalStorageLimit = 1
ThirdPartyStorage = 1
AssetCacheSize = 10
AutoUpdateDisable = 1
LegacyDomainMatching = 0
LocalFileLegacyAction = 0
AllowUserLocalTrust = 0
# DisableSockets = 1
OverrideGPUValidation = 1
EnableLinuxHWVideoDecode=1

## Change the Device section in /etc/X11/xorg.conf to look like the below
## If no such file exists copy the below into a file named /etc/X11/xorg.conf and restart

# /etc/X11/xorg.conf

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “NoLogo” ””
Option “RenderAccel” “1”
Option “MigrationHeuristic” “greedy”
Option “TripleBuffer” “true”
EndSection

## This is quite specific for my machine but might help you out as well
## create or edit /etc/modprobe.d/nvidia-kernel-common.conf to look like below
alias char-major-195* nvidia
options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=44 NVreg_DeviceFileMode=0660
options nvidia NVreg_EnableMSI=1 # optional for a small performance increase
options nvidia NVreg_Mobile=1 # optional for a small performance increase
blacklist nouveau