Page 1 of 1

Re: Latex and xdvi command [Solved]

PostPosted: April 21st, 2017, 3:03 pm
by prudra
I know it is really about Latex, but I have not yet got an answer on Latex Forum. Maybe somebody here have the answer.

On my Debian Jessie Mate DE laptop I have texlive-latex3 installed. I have a number of `\includegraphics{figure.eps}' in the `file.tex' file. As long as the total file length was small there was no problem of showing the figures when I ran `xdvi file.dvi &' after running `latex file.tex' . But when the file grew somewhat larger, then for the figure only the boundary was appearing, but nothing inside the boundary. But if I ran `xpdf file.pdf &' after running `latex file.tex' and `dvipdf file.dvi', then the full figure was appearing. So it seems that the full figure was being generated by latex command but was not being shown by the xdvi command. Also after running the xdvi command on the terminal appeared

rudra@mahasagar:~/groups$ xdvi group.dvi &
[1] 2737
rudra@mahasagar:~/groups$ gs: Unknown device: x11
gs: Unrecoverable error: undefined in .uninstallpagedevice
gs: Operand stack:
gs: defaultdevice
xdvik: read_from_gs: Connection reset by peer

This is not causing any harm but is a nuisance.
I shall appreciate help in solving the problem and avoiding the nuisance. Thanks.

Re: Latex and xdvi command

PostPosted: April 26th, 2017, 3:58 am
by prudra
After #apt-get install ghostscript-x everything is running fine.