missing libs after upgrade

Discussion of technology related topics including news, events, and announcements.

missing libs after upgrade

Postby nodir » September 17th, 2016, 5:28 pm

After installing and upgrading Slackware i can't start xfce as libcule.so is missing.
When using slackpkg to search for it, awk complains that libsigsegv.so is missing.
I also get error messages about the gpg key.
slackpkg update gpg doesn't change that.

To upgrade i followed the steps mentioned here:
http://docs.slackware.com/slackware:slackpkg
nodir
 
Posts: 245
Joined: June 16th, 2015, 10:10 pm

Re: missing libs after upgrade

Postby cynwulf » September 23rd, 2016, 12:44 pm

Unfortunately, that's only a rough guide to package management.

The steps to upgrade are detailed here:
http://mirror.bytemark.co.uk/slackware/ ... PGRADE.TXT
User avatar
cynwulf
 
Posts: 2504
Joined: April 26th, 2011, 2:46 pm

Re: missing libs after upgrade

Postby nodir » September 23rd, 2016, 1:59 pm

Thanks.
The problem was that i upgraded from 14.1 to 14.2
Was a bit astonished that such might give problems.
nodir
 
Posts: 245
Joined: June 16th, 2015, 10:10 pm

Re: missing libs after upgrade

Postby cynwulf » September 26th, 2016, 2:12 pm

Upgrades are "manual" in nature and 14.1 to 14.2 is actually quite a big transition as it's been years since he has released anything.

If you don't follow upgrade.txt, things generally will go wrong... been there and done that...

I suppose Debian was/is the same. If you didn't follow the release notes, for certain dist-upgrades things could go horribly wrong. Nowadays it might be different as no doubt it's "easier" and automatic...
User avatar
cynwulf
 
Posts: 2504
Joined: April 26th, 2011, 2:46 pm


Return to Technical Talk

Who is online

Users browsing this forum: No registered users and 1 guest

x